Topic-icon Problème d'url

Plus d'informations
03 Mar 2015 14:41 #8041 par Eouzan
Message
Bonjour

Je gère un site de vente en joomla 2.5 +virtuemart hébergé par Siteground et il se trouve que quelques URL des pages "produit" s'affichent de manière inattendue
La plupart des URL s'affichent ainsi: www.monsite.net/nom-du-produit alors que d'autre produits pourtant enregistrés de façon identique affichent un URL sous ces formes:
www.monsite.net/nom-du-produit1/com-virt...menu-shipmentmethods
www.monsite.net/lnom du produit2/com-virtuemart-menu-store/com-virtuemart-menu-store
www.monsite.net/nom-du-produit3/com-virt...rtuemart-menu-report
et ainsi de suite pour 9 d'entre eux avec toujours des ajouts différents:
/com-virtuemart-menu-orders/com-virtuemart-menu-orders
/com-virtuemart-menu-manufacturers/com-virtuemart-menu-manufacturers
/com-virtuemart-menu-mediafiles/com-virtuemart-menu-mediafiles
/com-virtuemart-menu-configuration/com-virtuemart-menu-configuration
/com-virtuemart-menu-users/com-virtuemart-menu-users
/com-virtuemart-menu-paymentmethods/com-virtuemart-menu-paymentmethods
La suppression de ces partie finales par exemple:
www.monsite.net/nom-du-produit1 ouvre la page d'accueil.
Je suis désemparé car je ne trouve aucune différence d'enregistrement entre les différents produits de la catégorie et du menu qui les contiennent.
Avec mes sincères salutations
Hervé Eouzan

Vous devez vous connecter Connexion pour prendre part à la conversation.

Plus d'informations
06 Mar 2015 11:49 #8050 par C-Jay
Réponse
Hello,

Surprenant en effet, surement du à cause d'éléments de menu.
Utilise-tu sh404SEF ?
Le système de réécriture d'URL natif de Joomla est assez léger.

A la recherche d'un hébergement / hébergeur Joomla spécialisé, performant et sécurisé ? Choisissez SiteGround (Nouvelles offres : -50% sur leur offre Start Up !)
Découvrez le guide Réussir son entreprise sur Internet grâce à Joomla
Découvrez le le centre de formation NosyWeb
Cet utilisateur a été remercié pour son message par: Eouzan

Vous devez vous connecter Connexion pour prendre part à la conversation.

Plus d'informations
06 Mar 2015 13:15 #8052 par Eouzan
Réponse
Bonjour
En fait le problème venait de l'apparition de tous ces parasites dans la liste déroulante "Lien parent" du menu contenant les produits.
Malgré mon choix "Lien de menu racine" rien n'y faisait.
J'ai alors supprimé ce menu, la réécriture des URL, désactivé la SEO et reconstruit le menu puis remis la réécriture et la SEO en place.
Depuis tout semble être revenu à la normale.
Je ne connais pas l'origine de ce dysfonctionnement.

Merci et salut
Hervé Eouzan
Cet utilisateur a été remercié pour son message par: C-Jay

Vous devez vous connecter Connexion pour prendre part à la conversation.

Plus d'informations
06 Mar 2015 14:20 #8053 par C-Jay
Réponse
Merci pour ton retour :-)

@bientôt.

A la recherche d'un hébergement / hébergeur Joomla spécialisé, performant et sécurisé ? Choisissez SiteGround (Nouvelles offres : -50% sur leur offre Start Up !)
Découvrez le guide Réussir son entreprise sur Internet grâce à Joomla
Découvrez le le centre de formation NosyWeb

Vous devez vous connecter Connexion pour prendre part à la conversation.

Modérateurs: C-Jay
Temps de génération de la page : 0.724 secondes
Contact

Scoop.It de NosyWeb

Twitter de NosyWeb

YouTube de NosyWeb

Facebook de NosyWeb

Google+ de NosyWeb

Flux RSS de NosyWeb

Inscription newsletter de NosyWeb