logo pluginIl est fort fâcheux qu'un plugin devienne incompatible lors de la migration entre Joomla 1.5 et 2.5 mais il existe une solution à ce problème. Dans cet article, je vais vous expliquer comment convertir un plugin Joomla 1.5 en plugin Joomla 2.5.

 

icone outilEtapes préliminaires

Pour commencer, veuillez suivre les étapes suivantes :

  • Connectez vous au back-office de votre Joomla 2.5 et installez le plugin Joomla 1.5.
  • Rendez vous dans le dossier du plugin (avec FileZilla). Le chemin d'accès est en général : plugins/type du plugin/nom du plugin.
  • Récupérez le fichier XML du plugin. Ce fichier à souvent le même nom que le plugin.

icone outilModification du fichier XML

Pour l'édition du fichier XML, je vous conseille d'utiliser le logiciel Notepad++. Maintenant, il va falloir remplacer certaines lignes de code du fichier, en commençant par :

<install version="1.5" type="plugin" group="system">

A remplacer par :

<extension version="2.5" type="plugin"  group="system">

 

Remplacez :

<params>

Par :

<config>
<fields name="params">
<fieldset name="basic">

 

Remplacez :

<params group="advanced">

Par :

<fieldset name="advanced">

 

Remplacez :

<param name="plugin_parameter" ... >
</param>

Par :

<field name="plugin_parameter" ...>
</field>

 

Remplacez :

</params>

Par :

</fieldset>

 

Remplacez :

</install>

Par :

</fields>
</config>
</extension>

 

Maintenant que les modifications sont faites, il ne reste plus qu'à sauvegarder et de remplacer le fichier XML original par le fichier XML que vous venez de modifier.

Comme toujours, je vous conseille de faire une copie du fichier original, au cas où, le nouveau fichier provoque quelconque problème.
 

Source : Convert a simple plugin for Joomla! 1.5 to 1.7

Cet article vous a plu ? Abonnez-vous à la newsletter NosyWeb !

L'auteur : un expert à votre service
Geoffrey LEOST
Nom : Geoffrey LEOST

Commentaires (1)

This comment was minimized by the moderator on the site

Bonjour,
J'ai essayé avec le plugin fboxbot (joomla 1.5), mais sans succès car il manque des variables dans le fichier .xml.
D'ailleurs pour migrer vers joomla 2.5, même si on choisi un autre plugin pour gérer les "images" en pop up, est-il...

Bonjour,
J'ai essayé avec le plugin fboxbot (joomla 1.5), mais sans succès car il manque des variables dans le fichier .xml.
D'ailleurs pour migrer vers joomla 2.5, même si on choisi un autre plugin pour gérer les "images" en pop up, est-il possible que le nouveau plugin conserve les effets initialement créés par le plugin fboxbot ? Sinon cela obligerait de reprendre des centaines d'articles et photos...

Lire la suite
Il n'y a pas encore de commentaire pour cet article.

Ajouter vos commentaires

  1. Insérer un commentaire en tant qu'invité.
Pièces jointes (0 / 3)
Share Your Location
Contact

Scoop.It de NosyWeb

Twitter de NosyWeb

YouTube de NosyWeb

Facebook de NosyWeb

Google+ de NosyWeb

Flux RSS de NosyWeb

Inscription newsletter de NosyWeb

 

Restez à l'affut de l'actualité NosyWeb ! :-)